Results 1 to 7 of 7

  1. Sad
    #1

    New PC issue

    FML always seem to have an issue these days when buying something tech related

    So I picked up a new PC from Computer Lounge last Friday and it already seems to be having a small issue.

    A couple of times when I've turned on the PC the power comes on but there's no display and it doesn't boot up. Also the CPU fan isn't spinning and doesn't light up like the rest of the PC. I can hear the GPU fans spinning and they seem to be going faster than normal at bootup. When I do a hard reset everything works normally again. Out of the 5 or 6 times I've turned it on this issue has happened twice. Both times it has happened after been off for the night.

    Ryzen 7 3700X
    Wraith Prism Cooler
    ASUS GeForce RTX 2070 Super STRIX Advanced Graphics Card
    Corsair Vengeance RGB PRO 16GB
    Gigabyte NVME 512GB M.2 SSD
    ASUS ROG STRIX B450-F Gaming Motherboard
    Corsair RM650 PSU

    Do you guys have any idea what it is? I could live with it but there's probably an underlying issue & it is brand new so I expect it to work flawlessy. Should I just take it back to CL? Seeing as its an intermittent issue it might be a bit hard to diagnose.

    cheers

  2. Post
    #2
    Ins0mn1ac wrote:
    FML always seem to have an issue these days when buying something tech related

    So I picked up a new PC from Computer Lounge last Friday and it already seems to be having a small issue.

    A couple of times when I've turned on the PC the power comes on but there's no display and it doesn't boot up. Also the CPU fan isn't spinning and doesn't light up like the rest of the PC. I can hear the GPU fans spinning and they seem to be going faster than normal at bootup. When I do a hard reset everything works normally again. Out of the 5 or 6 times I've turned it on this issue has happened twice. Both times it has happened after been off for the night.

    Ryzen 7 3700X
    Wraith Prism Cooler
    ASUS GeForce RTX 2070 Super STRIX Advanced Graphics Card
    Corsair Vengeance RGB PRO 16GB
    Gigabyte NVME 512GB M.2 SSD
    ASUS ROG STRIX B450-F Gaming Motherboard
    Corsair RM650 PSU

    Do you guys have any idea what it is? I could live with it but there's probably an underlying issue & it is brand new so I expect it to work flawlessy. Should I just take it back to CL? Seeing as its an intermittent issue it might be a bit hard to diagnose.

    cheers
    Take it back.

  3. Post
    #3
    Yep, it's a CL issue. They should sort it no problem.

  4. Post
    #4
    Already Pm'd

  5. Post
    #5
    Noice

  6. Post
    #6
    Sounds like a RAM training, used to get this when I pushed my memory frequency to high on older gen ryzen.
    CL will sort you out in any case

  7. Post
    #7
    Just leave the PC on and don't turn it off, problem solved

    CL have awesome after sales support, they will sort you out

    And don't worry you're not alone. I've had the occasional bad luck with new tech in the last couple years as well.